First_won_time in the deal is '0000-00-00 00:00:00'

Hello, we have a problem with the deal - it somehow has first_won_time property in the API JSON object set to ‘0000-00-00 00:00:00’ which is an incorrect date and our ETL integration does not work. Can you fix this and prevent from happening again please?

Hi @Vladimir123,

Are you see the same result in-app or just via the API return? Also, as I can’t see this deal (without being logged into your account), this deal has been won?

Hi David, there is not first_won_time field visible in the app.

As for the status of the deal - it is “deleted”

Thanks for the followup.

In this case, 0000-00-00 00:00:00 is just a placeholder then as it, like you stated, is a deleted deal.

Hello David, if I undelete the deal this placeholder does not go away. Also, this deal was having NULL in this placeholder up to Feb 22nd when we have simply removed the organization from that deal. After that the API started to give as 0000 value which is an incorrect date and can not be treated as a placholder. There should be null.

It seems the only way this is possible is if the deal was imported with this information already filled out (which our Support Engineers found to be the case here).

Hi David, that is the point. The deal was imported in dec 2018 and ETL correctly worked and first_won_time was null. All was fine until Feb 22 2019 when we have unliked organization from the deal. After that time first_won_time suddenly started to return 0000-00-00 which is wrong. This date can not be treated as a placeholder as it should be null. in that case