Scope and URL mismatch 403

Hello team
I have access_token and i am passing it in ‘Authorization: Bearer’ for searching the person with phone number.
I have try to run the api from code as well from the postman, on both the end i got this response :
(
[success] =>
[error] => Scope and URL mismatch
[errorCode] => 403
)

I my self has the sendbox account where i installed the pipedrive app and have all the access to person module as i have create a data in person module in pipedrive.
App also has all the possible permission.

I run the api on this url : https://developers.pipedrive.com/docs/api/v1/#!/Persons/get_persons_search with passing the api_token, it work here, what is the issue with curl and postman.

Please help,
Thanks

Hi @Amit_patel

Could you send me an example of the URL for the endpoint(s) you’re trying?

Yes @David

I try following :
https://[api-domain]/v1/persons/search
https://[api-domain]/api/v1/persons/search

both gave same error, and the app have all the permisions.

Thanks

Can you remove the “v1” and try again?

Hello @David

Okay, I tried with following, but same error :
https://[api-domain]/persons/search
https://[api-domain]/api/persons/search

Thank you

Hello

Issue solved, I was getting issue because of wrong methos"POST", the request was for GET,

Thanks

1 Like