Activity active_flag default behaviour changed?

I’ve just noticed something different. When updating or adding activities to a deal via the API, if I don’t set the active_flag to true, the activity is added, then disappears.

Looking at it, it seems this is used to flag an activity as deleted.

I’m sure this wan’t happening when I first started using this endpoint.

I’ve now updated by code, but just posting here in case anyone else has discovered this, or wasn’t aware of it.

Hi @micahsdad1402,
It sounds a bit strange… So you’re trying to add the activity, it’s added and then it disappears?
What endpoint are you using exactly? With what parameters?

I’m using

bascially, if I include the parameter active_flag=true it works. If I don’t include this parameter it does the odd behaviour.

This definitely is different to when I first wrote the code. I’ve had no clients report this issue, and I just noticed it myself going through some testing for a new release. I then checked my previous version, and it did the same thing.

So it’s clearly a change to the way the endpoint works. No documentation on this, so I thought I’d just share it here in case anyone else has the same issue.

When I use the API Reference, it creates the activity with active_flag set as true. So it could be an issue with how restsharp serialises the c# class that is causing this.

I’m using c# with restsharp.dll

I suspect it might be something on your side.
I just double-checked and everything seems ok, meaning that if I don’t pass active_flag, it’s automatically set to true.

If you have the time, you could verify yourself using Postman or a similar tool, to exclude your libraries and code.

Let me know how it goes if you do :+1:

I’ve got it working and very busy at the moment. There are at least three or four layers of dlls to create a post, so trying to duplicate this would take too much time, especially when I have a simple solution of just setting the flag to true.

Thanks for the contributions.

1 Like