Bug: Get all deal fields is limited by default 100

The endpoint Get all dealfields: get/dealFields returns all dealfields with a default limit of 100. This limit is not documented nor it has any benefit on this endpoint.
Can this be changed in the documentation? Or remove the limit by default in the API call.

See reference: Pipedrive API v1 Reference

Hey @dfeldbrugge, it should show on the limit field under GET deals

I understand this is set for the Get all Deals. But this is about the Get all DealFIELDS. The documentation doesn’t state any of these settings on this endpoint.

Yeah, good point. I misread it initially.

But you can change your default of 100 to 500 (max) by adding &limit=xxx

I know and allready did this, because I was debugging. But I think this needs to be documented well.
Maybe in the developerspage you can add the same fields from Get all deals also in the Get all dealfields settings.

Thank you - this was driving me nuts and this was the only place I could find the answer. Support pointed me to this community but not to this page. Is there any way to boost the limit to 1000 or more? I’m using PowerBI to pull data in and need to get records 501 +.

Actually, I found the documentation - https://pipedrive.readme.io/docs/core-api-concepts-pagination

1 Like

Hi Bill, I’m passing through the same, Did you get a solution to get more than 500 rows in Power BI?