GET mailbox/mailThreads/{id} returning 404

My hope is to associate mailThreads with a given deal. To do that, though, I need the mailThread object so that I can run the PUT with the deal_id.

When I imported a new user from our email campaign, I then hit v1/persons/{id}/mailMessages, which works as expected. From this, I grab the unique mail_thread_ids from those messages, and I tried passing them to GET v1/mailbox/mailThreads/{id} a la the documentation here. However, when passing this mail_thread_id I get a 404. Additionally, when I get v1/mailbox/mailThreads?folder=sent, I get an empty list returned.

I’m I treating the mailbox incorrectly, or what’s going on? Thanks so much in advance!

Hello @hewitte and welcome to the community! :wave:

I have reached out to you via private message to gather some additional information, so we can investigate this!


I’m having the same problem. Unfortunately you worked out the solution offline and didn’t follow up here. @Helena_Sul would you be able to follow up with me too? Thx.

This has not yet been resolved, even offline @joefitz – sorry!