GET Search Results has changed its behavior?

A few weeks ago I started doing a GET Search Results request using a phone number to search for deals. This worked great because I could find deals associated with a Person with a particular phone number.

It seems in the last week or so that those searches have started failing. Has something changed in the logic here?

Otherwise, what is the best way to find Deals using the API when I only have a phone number to search for?

Hi @Reefpirate

Do you happen to have an example of a search that is failing and the corresponding number (use a test number if possible) so I can test how you are currently doing your search?

Sure, the test phone number: 543-543-5432 does return a result in the Pipedrive web client search, and it also returns results including the deal if I do the API search without an ‘item_type’. However, it does not find any deals when I use ‘item_type=deal’.

No results:

2 results (Person and Deal):

I’ve worked around the new behaviour, but it’s strange to me that last week both of those API searches would have returned the Deal I need and now one of them does not.