HTTP 400 on custom Org field PUT, API Token, prod environment. Works for deals, works in Sandbox


I’m getting an HTTP 400 response while making a custom field value update PUT call for a custom Organization “user” type field in our live production account environment.

The same request/format is working fine in Sandbox (with appropriate tokens, orgs, etc.), and Deal PUT requests with basically an identical call work fine in the live environment.

The PUT call attempts are with both Postman and even CURL as an alternative test, with a JSON body (header Content-Type: application/json and Accept /).

I’ve tried multiple valid API Tokens, tried with several different valid Org IDs and even 3 different URL formats (all three base URLs work for the Deal updates).

URL Formats tried:

PUT https://{COMPANYDOMAIN}{ValidOrgId}?api_token={validApiToken}
PUT https://{COMPANYDOMAIN}{ValidOrgId}?api_token={validApiToken}

Sample CURL request:

curl -v -H ‘Content-Type: application/json’ -X PUT
-d ‘{“f41708c01143be5aab667a537a8752a52f1114f”:11270214}’

Attached images are from Postman, and show the custom field definitions for both Org and Deal (both have a custom field named “Primary Account Manager”), and example requests for both, with the failing organization update, but successful and similar deal update.

Anything obvious here? Something broken?


This is resolved. The only issue turned out to be a copy/paste error in a field key. Everything else was/is working as it should. Thank you PipeDrive support for the extra set of eyes.

1 Like