Implementing OAuth flow to get to the marketplace

Hello Team!

Our developers are trying to realize the logic described in this docs App installation flows in order to set up the required installation flow for publishing on the PipeDrive marketplace.

We tried to implement the same logic as Zapier did but faced some difficulties. PipeDrive developers recommended to use the state parameters described here State parameter but it didn’t help, however they enabled it in our account. So the problem is described below:

Except “Callback URL (redirectURL)” our developers were trying to find the “Install URL” in the app’s settings, so that the system initially redirects to that “Install URL” but not to the https://oauth.pipedrive.com/oauth/authorize?client_id=10f6b602cda330ef&redirect_uri=CALLBACKURL

It is how the Zapier’s logic works, but we didn’t find such option in the Pipedrive’s UI.

In Zapier case when you click Install from the Pipedrive’s site the system redirects you to the page “Allow Zapier to access your Pipedrive Account?” with the address https://zapier.com/engine/auth/start/PipedriveCLIAPI/ and only after it it redirects you to the https://oauth.pipedrive.com/oauth/authorize?client_id=10f6b602cda330ef&redirect_uri=https://zapier.com/dashboard/auth/oauth/return/PipedriveCLIAPI/&state=1643376822.60074314489&response_type=code where parameter rediret_url differs, so they somehow don’t use Callback URL to install from PipeDrive website.

Could you assist us with it? We’d like to realize the same logic as Zapier does.

Thanks!

Hey @SergeiK

Welcome to the community :slight_smile: !

I realize that the feature to add a state param & custom install URL has been enabled for your account but you were not able to find it? :thinking:

You should notice something like this (Installation URL below callback URL field)

with a preview that looks like this

Let me know if I am missing something

Hi there! I think that the problem is that we don’t have such field in our account. Here is the screen:
image

Maybe it was not enabled till the end, could you please take a look at it?

@SergeiK I have reached out to you via DM for further details. Let me cross check it once from my side

Hi! Replied to you there.

1 Like

This has been enabled now. Kindly confirm. Seems like it was not enabled for that account before.

Thank you! We can see it.

1 Like