HTTP API Request


I am using for some automations, however, I have an issue.

When trying to automate leads, I can’t seem to insert a note.

The create a note module is only available for deals, not leads. I thought about doing an HTTP request with the Make module. I am encountering a 401 unauthorized access.

I am not sure what I am doing wrong, that just I am.

Can someone assist?


The 401 error means that your authentication isn’t being approved at the Pipedrive end.

There’s an easier way to do this however … you can use the Pipedrive app’s Make an API Call module. That uses the same authentication and connection mechanism as you’re already using for the other Pipedrive modules in Make.

You can use that technique for any API endpoint that isn’t exposed as a module in Make.

Hey David!

Thank you for the reply, much appreciated! and for the tip, didn’t know it existed, I previously tried the regular make api.

I tried your way, but it gives out a 404: Not Found (undefined), but again, it all seems correct. I’d appreciate it if you can take another look and help out:

Thank you :pray:t3::pray:t3::pray:t3:

The URL you specify in the Make an API Call module should be relative to rather than a complete explicit path.

So in your case all you need in the URL field is just notes

1 Like

That worked!

David you legend, I really appreciate it.

May you will always be on the giving side :pray:t3: God bless

You’re very welcome!