Persons search endpoint not working as intended


We have been using the /persons/find API endpoint to get matching persons, this has worked fine.
However we just noticed that this endpoint is now returning null instead of a list of matches.

The API documentations suggests that the above endpoint is deprecated, so I’ve tried the newer /persons/search endpoint, but it’s returning an empty list.

This is what the deprecated endpoint returns:

  "success": true,
  "data": null

and the newer search endpoint returns an empty list, example:


returns :

  "success": true,
  "data": {
    "items": []

Looks like we are not getting matches either way. Can you please help look into this?
Happy to provide more info if needed.
Thank you!

Hi @vwei_ac

I made a similar request with my Pipedrive data

Taking into account that I have a person with email = (for testing only), I got next result

I understand that you cannot expose email you searching for here. Could you remove exact_match key from request and check what would be the result? Maybe email term does not exact match to email value.

1 Like

Hello @mykhailo thanks for looking into this!
I just tried again with the same parameters and it works (both old and new). While I’m not sure what happened last week I’m glad it is back to normal :slight_smile:
I do have a follow up question about the deprecated endpoint (/persons/find): do you happen to know when it will stop working completely? What’s the best way for developers to receive updates on these deprecations so we can plan for the update ahead of time?


1 Like

Hi @vwei_ac

GET /persons/find

will be deprecated on 31 March 2021.

You can find this info here in the future

1 Like