Setting monetary field to null


I’m trying to update deal’s custom monetary field to null, but can’t do it. I am testing this with Postman (PUT request to {{baseUrl}}/deals/302/{{dealId}}).

Sending numerical values works as expected, but I cannot get it to null (tried “”, " ", null, NULL, ‘null’ and who knows what else :slight_smile: It always ends up as 0.

Hello @petar !
Can you share the body sent in the request?
You can share it via PM if you prefer as well.

Hi @Edmilson_Souza ,

here is the screenshot from Postman:

Not sure how to get raw body of request… ‘1bf45…’ field gets the value of 0, everything else is OK.

I guess this is the issue, the endpoint expects a raw JSON body, that should also allow to use null as a value.

1 Like

Yes, that’s right. Posting body as raw JSON and setting monetary field to null does the job.

Thank you for the help!