Timestamps are not recorded according to the timezone setting

#1

As the subject saying, I found when I added a deal, then fetched the deal details by making api call, the timestamp is different from my current timezone settings. Is there a way to record the ‘right’ time? Thanks in advance.
Update: the timestamp on individual deal page is recorded properly with my timezone setting. but not the api call deal detail records.

#2

Hi,
all times are UTC, so you just need to convert them to your local time zone :+1:

Also when sending a specific time, for example when you’re planning an activity, you should send the UTC time.

Hope that helps

#3

https://pipedrive.readme.io/docs/core-api-concepts-date-format

1 Like