Update enum fields (custom) not work

Hello to all, i create custom fields that is single option, when i am trying to update, all the fields are saved beside this field (all other fields are text, my test i am doing on postman) .
what i am doing wrong ?


Hi Ofir. Can you post a snippet of the request you’re sending?

Hey guys –

I have the exact same problem. It stopped working 2 days ago. I can update normal fields for organisation, but not custom fields.

Here’s the call:

PUT /v1/organizations/xxx?api_token=xxx HTTP/1.1
Host: api.pipedrive.com
Content-Type: application/json
Cache-Control: no-cache
“[custom-field-hash-here]”: “[value-here]”

Can you double check that the custom field is actually of the organization and not of a person, deal, etc.?

Hi Dani –

Yes, I checked, it’s definitely the right field. And it’s the same script we’ve been using for years, it just stopped working on 29.08.2018. This is currently blocking our internal data pipelines from functioning properly. Any clue how to speed up the process to get it fixed?


That’s strange. I just tested and it works fine for me.
Could you post a comprehensive snippet of how you build the request?

Here’s the curl:

curl -X PUT
-H ‘cache-control: no-cache’
-H ‘content-type: application/json’
-d ‘{
“[organisation-custom-field-id-here]”: “[enum-value-for-custom-field-here]”

Hi Dilbert.
I tried your same snippet and it works fine, but, I had to replace and with ' and ".

I don’t know if it was an issue with copy/pasting here, but can you try to double check those characters and try again?


It’s just how this text form formats stuff, but not the issue. I tried from Postman, cURL, and like I mentioned before the actual script we have kept working for years before few days ago. Maybe it’s something account specific? Is there any way to contact Pipedrive support?

All best!

Hey @dilbert

Yeah, I’m also thinking it might be account specific. Do you have several fields on your account already? Might be an issue with amount or otherwise (possibly) an indexing issue.

Hey @David

We have 21 custom fields for organisations :slight_smile:

However, it just started working. The exact same curl that wasn’t working hours ago, works now. So maybe some transient issue.