Updating deal through API not working - Postman

#1

Hi guys,

Trying to update a deal using Postman in preparation of some automation what I’m creating, but it doesn’t seem to be working. I’m probably doing something wrong, but I can’t find what.

So, details.

url: https://api.pipedrive.com/v1/deals/<DEAL_ID>?api_token=<TOKEN>
method: "PUT"
body: {
    title: "API test"
}

Executing this doesn’t do anything though. Not getting an error, but also not seeing the new name in the interface.

The raw output from Postman:

PUT /v1/deals/123?api_token=<TOKEN>

Request headers
Accept: application/json
cache-control: no-cache
Postman-Token: 0d42ffb6-e990-457f-baef-0df3c8caffa0
User-Agent: PostmanRuntime/7.6.1
Host: api.pipedrive.com
cookie: pipe-last-active=1554381842066
accept-encoding: gzip, deflate
content-type: multipart/form-data; boundary=--------------------------143229363281056449917951
content-length: 168

Request body
title=API test

Response headers
HTTP/1.1 200
status: 200
Content-Type: text/html; charset=UTF-8
x-correlation-id: 5b39ab8b-4941-4320-967a-6b4a10754f58
badi: Routing: eu-central-1=>eu-central-1; Version: 5d96;
Access-Control-Expose-Headers: X-RateLimit-Remaining, X-RateLimit-Limit, X-RateLimit-Reset
x-frame-options: SAMEORIGIN
Content-Encoding: gzip
X-RateLimit-Limit: 40
X-RateLimit-Remaining: 39
X-RateLimit-Reset: 2
Server: no-name-at-all
X-XSS-Protection: 1; mode=block
X-Content-Type-Options: nosniff
Date: Thu, 04 Apr 2019 12:44:07 GMT
Content-Length: 20
Connection: keep-alive
Vary: Accept-Encoding
Set-Cookie: pipe-last-active=1554381847438;path=/;domain=.pipedrive.com;expires=0
Strict-Transport-Security: max-age=31536000 ; includeSubDomains

Response body

Any help would be greatly appreciated!

#2

Hi Tiana,
what response are you getting?

Also, make sure you’re sending the body parameters as x-www-form-urlencoded.

1 Like
#3

Omg I’m an idiot. Thank you Dani!
There was no response though, the response was empty, which was why I was confused on what was happening.

1 Like