Zapier Error: Zap fails on initial run, but then succeeds on manual 're-run'

I set up a multi-step Zap, which was working until ~ March 6th, 2023.

Now the Zap will always error (error message below) until I manually re-run each Zap – and then it succeeds.

When I look at the errors within Zapier, I see this error in the logs:

While requesting “dev_method” from Pipedrive we ran into an error: The company does not have access to this feature Please check for more information about Pipedrive API.

Weirdly, I’m not able to reproduce this error with my Sandbox account.

1 Like

I have the same issue, and it also stopped working around March 6th 2023. The first Zap triggered by new PipeDrive deal produces the error, but works when I rerun, until it accesses Pipedrive once again in the Zap.

1 Like

I’m glad that I’m not the only one experiencing that problem since the 6th March. I haven’t changed anything in the Zaps but all connected to Pipedrive are running into that same error.

1 Like

I just started experience this error this morning, however I am not able to rerun the zaps. It appears that Zapier is having a degraded task log outage, so maybe that is why. Has anyone found a way to fix this, so that automation succeeds the first time?

We had this issue start for us last night at about 6:21 PM MST. I reached out to Zapier and they said it was because we didn’t have API access granted to the user accounts in Pipedrive and to re-enable it. Checked on that, and no permissions had been changed for API access. They then asked us to reconnect Pipedrive to Zapier and try to run the zap again, reconnection was done, the connection test was successful and the zap failed with the same error. I now have a list of errors piling up (they have a slow task list issue today), and every task is failing due to this issue. These are zaps that have been in place for over 6+ months to a year, with no issues until last night.

Very frustrating.

Here is the error message we are getting over and over today…

While requesting “dev_method” from Pipedrive (3.5.8) we ran into an error: The company does not have access to this feature Please check for more information about Pipedrive API.

We have a solution!

I got in touch with a support rep at Pipedrive, and they recommended a solution, which ultimately fixed the issue (though, it might be a workaround solution because this solution shouldn’t be causing this error).

Essentially though, you have to make sure ‘Products’ isn’t toggled off – once I toggled ‘Products’ back on within Settings, it solved the error in Zapier.

Here’s a quick walkthrough and explanation: Loom | Free Screen & Video Recording Software | Loom

I received this information from Zapier this morning:
"It looks like a new version of the Pipedrive integration was just released.

To provide some context, when an app version is updated, users and Zaps aren’t always automatically migrated at once. Generally speaking, new versions are released when bug fixes have been made or new features have been developed.

Now that your Zaps have been migrated to the new version, you should be able to replay any errored Zap runs. "

I have not been able to rerun all of mine yet to validate this, due to the task/zap history degradation issue.

Hello everyone! :wave:

Indeed, @Colleran has outlined the correct solution here:
To use deal-product features, you should have the Products feature turned on → Inside the web app, navigate to ‘Tools and integrations’ > ‘Products’ > check that the toggle is enabled.

Do let us know if there’s further questions!